________________/\\\_____/\\\\\\\_________/\\\\\\\\\\\_____/\\\\\\\\\________/\\\\\\\\\_______/\\\\\\\\\_______________         
  ____________/\\\\\\\___/\\\/////\\\______\/////\\\///____/\\\\\\\\\\\\\____/\\\\\\\\\\\\\___/\\\///////\\\_____________        
   ___________\/////\\\__/\\\____\//\\\_________\/\\\______/\\\/////////\\\__/\\\/////////\\\_\/\\\_____\/\\\_____________       
    _______________\/\\\_\/\\\_____\/\\\_________\/\\\_____\/\\\_______\/\\\_\/\\\_______\/\\\_\/\\\\\\\\\\\/______________      
     _______________\/\\\_\/\\\_____\/\\\_________\/\\\_____\/\\\\\\\\\\\\\\\_\/\\\\\\\\\\\\\\\_\/\\\//////\\\______________     
      _______________\/\\\_\/\\\_____\/\\\_________\/\\\_____\/\\\/////////\\\_\/\\\/////////\\\_\/\\\____\//\\\_____________    
       _______________\/\\\_\//\\\____/\\\___/\\\___\/\\\_____\/\\\_______\/\\\_\/\\\_______\/\\\_\/\\\_____\//\\\____________   
        _______________\/\\\__\///\\\\\\\/___\//\\\\\\\\\______\/\\\_______\/\\\_\/\\\_______\/\\\_\/\\\______\//\\\___________  
         _______________\///_____\///////______\/////////_______\///________\///__\///________\///__\///________\///____________
 ________________/\\\_____/\\\\\\\________/\\\______________         
  ____________/\\\\\\\___/\\\/////\\\____/\\\\\\\____________        
   ___________\/////\\\__/\\\____\//\\\__/\\\\\\\\\___________       
    _______________\/\\\_\/\\\_____\/\\\_\//\\\\\\\____________      
     _______________\/\\\_\/\\\_____\/\\\__\//\\\\\_____________     
      _______________\/\\\_\/\\\_____\/\\\___\//\\\______________    
       _______________\/\\\_\//\\\____/\\\_____\///_______________   
        _______________\/\\\__\///\\\\\\\/_______/\\\______________  
         _______________\///_____\///////________\///_______________

18-10-2022

PHP is een populaire open source programmeertaal voor algemeen gebruik. Deze programmeertaal kan in HTML worden opgenomen en is geschikt voor webontwikkeling. Een andere naam voor PHP is Hypertext Preprocessor. Het is cruciaal dat je webshop draait op een ondersteunde versie van PHP in plaats van een verouderde versie die niet meer wordt onderhouden. In dit artikel vertellen we je wat de laatste PHP update (8.1) inhoudt en waarom deze belangrijk is.

Wat houdt de 8.1 update in?

De meest recente PHP-release tot nu toe is versie 8.1, die beschikbaar is gesteld op 25 november 2021. Deze nieuwe versie voegt nieuwe mogelijkheden toe, verbetert de bruikbaarheid, verhoogt de efficiëntie en maakt PHP klaar om schonere code te produceren door verouderde (ongewenste) functionaliteiten te beperken. Bovendien zijn er functies opgenomen die defensief programmeren moeten bevorderen, waardoor de beveiliging van uw website wordt verbeterd.

Een verbeterde performance

De nieuwe versie verhoogt de snelheid van uw website door bewerkingen sneller en met minder geheugengebruik uit te voeren. Hierdoor laadt je website sneller en wordt de server minder belast. Hieronder vindt u vergelijkingen tussen de verschillende versies. Hoe beter, hoe meer verzoeken per seconde (req/sec). 
WordPress 5.9-RC2 PHP 7.2 benchmark results: 106.56 req/sec 
WordPress 5.9-RC2 PHP 7.3 benchmark results: 108.45 req/sec
WordPress 5.9-RC2 PHP 7.4 benchmark results: 110.24 req/sec
WordPress 5.9-RC2 PHP 8.0 benchmark results: 111.10 req/sec
WordPress 5.9-RC2 PHP 8.1 benchmark results: 163.43 req/sec

Er is geen twijfel mogelijk dat PHP-versie 8.1 veel sneller is dan eerdere versies. Zelfs 32% beter dan PHP 8.0. 

Wat moet ik als webshop eigenaar doen?

De efficiëntie en snelheid van uw website worden verbeterd wanneer u de meest recente versie van PHP gebruikt. Dat wil je als webshop-eigenaar natuurlijk wel, want het vergroot je vindbaarheid en consumentenervaring. Het is daarom van groot belang.

Wat als ik niks doe?

Elke versie van PHP krijgt twee jaar volledig onderhoud, inclusief beveiligingsupgrades en bugfixes. Na de eerste twee jaar blijft de betreffende versie nog een jaar beveiligingsupdates krijgen totdat de ondersteuning volledig wordt stopgezet. Als uw website een verouderde versie gebruikt, is deze onveilig en is er een reële mogelijkheid dat vijandige gebruikers er via een lek toegang toe krijgen en allerlei persoonlijke informatie krijgen (een datalek), of erger nog, uw website overnemen als gijzelaar (ransomware). 
PHP-versies 7.0 t/m 7.3 worden niet meer geüpdatet en zijn daardoor bijzonder gevoelig voor gevaren. De enige updates die voor versie 7.4 worden aangeboden, zijn de kritieke beveiligingsupdates en dit is dus eigenlijk ook niet voldoende.

Laat SupportDesk je helpen

Het is cruciaal om maatregelen te nemen om problemen met uw online winkel te voorkomen. Neem daarom contact met ons op, zodat we samen de beste manier van handelen voor uw winkel kunnen kiezen.